Universal Robots Forum

UR Sim 3.5 etc. running RT and RTDE interfaces without the pendant java program?

We use the ursim 3.5 offline simulator and 5.1 as well, and for both we are looking for a way to run the URControl and have the RT interface (port 30003) and RTDE interface (port 30004) without the graphical interface (GUI)

We’ve tried adding a -Djava.awt.headless=true flag to the start-ursim.sh script but that doesn’t work because something still tries to launch the splash screen

So we tried to remove the java program invocation altogether, and only use the URControl program. When we do, the RT interface (port 30003) boots up and we are able to send URScript programs to the system, the RTDE interface (port 30004) boots up but does not send any messages because of a safety issue:

nc -v localhost 30004
Connection to localhost 30004 port [tcp/] succeeded!*
NMSafetySetup has not been confirmed yet, therefore no data will be send yet

And in simulation, there really isn’t a way to ‘confirm’ the SafetySetup is there? Or bypass it? So we can start streaming real-time data from this port again

2 Likes

What about just executing “starturcontrol.sh” in the URSim folder?
This starts URControl without PolyScope.

1 Like

what i mentioned doing about removing the java invocation in the original post calls ./starturcontrol.sh underneath

URControl starting without PolyScope is possible, but not actually it is waiting for safety confirmation

maybe an older version of the UR simulator does not have this check?