Universal Robots+

Standard Gateway Adress is set to Robot IP after restart

Software version: …5.4.3
Robot generation: … UR10e #20195000516

Steps to reproduce:

  1. First step
    Setup the STATIC IP Adress:
    Robot 192.168.100.5
    Mask 255.255.255.0
    Gateway 192.168.100.1

  2. Second step
    Restart Robot

Expected behavior:
Gateway Adress is Still 192.168.100.1
Actual behavior:
Gateway Adress is set to the Robots IP: 192.168.100.5

Having this Bug, we can’t use our desired Remote URCap Update solution so, @Ebbe, @jbm please fix this :slight_smile:

Does it work until you restart the robot?

Yes, but after restart, we can not initialize the remote SSH connection because of the overwritten Gateway Adress

I tried to add it from the terminal using “route add default gw 192.168.100.1” and then it seems to be persisted.
Hopefully this can work as a workaround until it is fixed.

1 Like

Do you have Profinet enabled?

Yes, Profinet has to be enabled.

this bug is still present. is there any suitable workaround? we actually overwrite the settings in the /etc/network/interfaces config file

Hi,

is there any news about this bug?