Setting up IP Address for UR5

Hallo everyone,
I am trying to establish contact between the robot and the computer directly using an ethernet cable.
My network on the computer looks like this:

then I set the IP address of the robot like the IP address of the computer, looks like this:

When I run this command(ping: it means there is contact between them.

but the EtherNet/IP adapter is not green and looks like this:

I work with remote Control:

Through a small Python program:
(from urx import Robot
robot.movej([1.5, 0, 4, 0 ,1, 2], a, v)
i tried to move my UR5 but the robot won’t move. Is this a correct way to move the robot?

I always don’t know what the problem is.
Can someone help me please.

Thank you very much.

The EtherNet/IP Adapter is not used for TCP/IP communication. It’s a communication protocol by itself like PROFINET.
So you should disable it to be sure it doesn’t interfere with anything.

For the robot to accept commands from any external source, the robot must be in Remote mode. It’s not enough to just enable it in the settings. You gotta change modes in the upper right corner by clicking on Local. :slight_smile:

EDIT: I haven’t worked a lot with Python, so can’t help you on that part. But might just be the wrong mode that’s preventing you from getting it to work.

1 Like