Universal Robots Forum

Screwdriving Node 3 Extra Until Nodes

Hi,

I have a small snippet of code that as of sdk 1.11.0 (and associated polyscope version 5.9), was working fine. I tried to run the same cap code on polyscope 5.10 and found it breaks, as well as on polyscope 5.11.

The small snippet of code simply creates a screwdriving node. In polyscope 5.9 it creates a Screwdriving node with 1 Until child node, which is correct, but in polyscope 5.10 and 5.11, it creates a Screwdriving node with 3 Until child nodes, which is incorrect. Keep in mind a Screwdriving node is only supposed to have 1 Success Until Node, but somehow my snippet of code is creating a node with 3 Until Nodes, each of which can choose a success condition. So you can potentially have a node with 3 Success nodes (which is normally not even possible).

Is this a mistake I made on my end (I’m thinking maybe something about the API changed about screwdriving nodes) or is this a bug? I also tried upgrading my SDK version to 1.12.0 (no higher though, because of CB3 compatilibity) which didn’t seem to change anything.

I’ve attached pics of my code and the resulting urcap node in my test cap in polyscope 5.10
Code
Polyscope

1 Like