Universal Robots Forum

Robot cannot maintain payload

I have been using a UR10 (CB3) for palletizing off a conveyor and it has been working great for a while. On Monday morning, I attempted to add a blend to a waypoint and the robot had a meltdown. I was getting C155A0 errors and could not get the program to execute.

After observing a little more carefully and was playing around with different programs and installations to ensure it was not on just one. I found that when it is not running the program it will pull the payload from the installation file. However, as soon as the program begins to run, the payload on goes to 0. It is also ignoring the set_payload commands in the program. This is happening on different programs and installation files and not just the one I initially had edited.

I am using it for a palletizing function so I have the TCP payload set in the installation file and use set_payload when picking up and dropping off the boxes and this has worked fine on them until now.

I tried to reset the TCP location and payload and have tried making a new installation file with no success. Has anyone heard of this happening before?

Have you updated Polyscope recently? A couple of point version ago they changed the Set command and removed the Set Payload section of it, creating a new Set Payload node that is just for setting Payload.

If you remove the blend radius does it still run? Maybe try a smaller radius or slower accel.

Other than that I got nothing.