Remote desktop to the controller UI

Does anyone managed to make a remote desktop connection to the controller in order to see the UI on a PC?

On google I have found that someone has solved this issue installing a VNC server on the controller.
Is this the “official” way? Does the installation of the VNC server have some impacts on the controller performances?



Ive manager to made A script for installing x11vnc on ubuntu Directly from polyscope with USB package. Works great

Hello ,

I am also looking for same kind of solution.Can you please elaborate the steps to do it
Thank you

Hi Rohan
Please write me on and i Will send you the package👍

Mvh Jonathan Skov

I have used VNC and it works great just requires a bit of setup and you to be comfortable with the command line interface.
You could use something like which also works well. It is paid but worth the value when you get remote access and statistics as well.


Hi, here is the package i prepared for easy instalaltion. Read the readme file to get started. It works similar concept as magic files for installation. (1.7 MB)


If you are comfortable with the command line, we solved it as follows:

  1. ssh into the robot
  2. make sure the line in /etc/apt/sources.list starting with deb-src is not commented
  3. Install screen and x11vnc:
    • apt-get update
    • apt-get install screen
    • apt-get install x11vnc
  4. Add the following line to /etc/rc.local (obviously, somewhere above exit 0) so that vnc server is started automatically:
    screen -dmS vnc x11vnc -forever -clip 800x600+114+85 -scale 734x576
  5. Reboot robot and test with a vnc client.

You may need to play with the clipping and scaling since they may vary depending on the linux version.



I had a question concerning the URMagic_VNC_Installation_V1 file. When plugging it into the robot, the shell file executes. However, once it is done, the VNC server does not seem to be active. Are there other actions which have to be performed?
It does work if I activate the x11vnc server in the shell myself. However, I thought that the whole point of using the URMagic_VNC_Installation_V1 is of not having to access the shell yourself.

I have not used or looked at the URMagic_VNC_Installation_V1 but I know after installing I had to reboot for x11vnc server to start. You may have already figured this out but thought I would say something.

1 Like


Yes indeed I already figured this out but in the files there is mentioning that the server should work immediately. However, I looked in the script files and don’t seem to understand why it does not work without a reboot.

Among the UR+ there is Robotiq offering Insights. A quick and good way to safely grant access to UR Cobots.


David Gouffé

Hi, using vnc viewer (from RealVNC), connection drop randomly.
Installed this magic file.
Anyone experinced that?

Just ran into this post and since weezy is now an outdated distro, I have a quick correction to sjansen’s solution:
On step 2 of his solution, we should change the deb-src line in sources.list to be :
deb-src wheezy main contrib

1 Like

AIRGATE actually offers remote operation of your UR collaborative robot, through an easy to use web-interface.
They also offer data sampling of the different inputs connected to your robot, so you can see exactly what is happening.

Check out AIRGATE - ARCS if you’re looking for plug 'n play solutions, or send me a private message here on the forums.

have to change file in /etc/apt/sources.list.d also.

Correct me if I’m wrong, but he e-series is running debian 8.9 which would be a similar line but jessie instead of wheezy

I don’t have an e-series here to test, but I believe so.

There are a lot of separate threads going on here. Yes, there are commercial solutions available for VNC on UR+: UR+ Products | Automate Faster

If you are doing this manually, just take note that updated Polyscope might break your installation and you would potentially have to re-do it.

Hi. I am not really comfortable with using command line,
I was sucessfull to install VNC on CB3 version with attached magic file but no luck in newer e-series.
Maybe somebody already modified magic file for e-series too ?