Profinet not connecting to controller in 5.13

Continuing the discussion from Problems with adjusting the IP-Address:

Hi, we are having similar problem now and trying to sort-our with local UR service support. However without success. We are deploying 2 UR10e 5.13 in automotive for high-torque screwing with Siemens S1200.

The profinet took over of network and have set gateway the same as IP. We can change the IP via Siemens. However the status is “yellow” no matter what we do. Profinet is enabled in services.
We have not experienced this kind of problem with profinet vs UR. And it is pretty urgent

we have tried with GSDML 2.31, 2.35, 2.42

// update - we have changed the gateway via PLC somehow = did not help

I don’t work with Profinet or Siemens myself, but I know they added the ProfiSafe capability somewhat recently. I’m wondering if there’s some additional setting in the PLC/UR that isn’t happy with this new setting? Sorry not much more help than that. Maybe dig in to ProfiSafe and what exactly was added. Good luck!

What is your network configuration? Is it through 1 Switch or Multiple?
Also, in the Topology view in TIA Portal, do you have a connection made there? Sometimes this can cause problems with the S71200 cpu’s. Only have the P/NE connection in the network view.

Hi, thank you for you recommendation.
We have made many test with everything also with UR tech support. Changed all the elements. At the end it was the “brainboxes” industrial switch that was causing the problems (we tried also another switch - apparently also that one did not work). What was even more perplexing there were another 2 profinet based devices that had no problem with the switch. Generally it took us 2-3 days to find out.

1 Like

J’ai déjà eu un soucis de ce type lors d’un retour de réparation du bras UR10e. Le software installé étant justement le software intégrant PROFISAFE.
Il a fallu downgrader la version de polyscope. Nous avons donc récupéré les fonctions correctement.
Un nouvel upgrade a permis de récupérer les fonctions PROFINET.
Avez-vous changé le nom du robot dans le projet TIA ?

Bon courage

Hi Bielik, So you got it working by changing the switch?