Universal Robots+

"No Controller" error on real robot

Hi,

I have an issue with our unviersal Robot, some times, the robot stop, and an error message show up “No controller”.
It happens with an UR 5 e-series, UR 5 CB series and also with one UR 10.
The robots are all up to date, equiped with On robot RG6 gripper with the UR-caps. This error happens when the program is running or not. When it show up, I have to restart the control bay to start the robot back on.

If you need more information or the log files, I can provide it.

Thanks you

Charles.

1 Like

This sounds like a topic for your local UR Distributor.
They should be able to help you troubleshoot this.

We’ve been plagued with this issue for over 2 years. Happens on almost all of our robots to some extent. Best we can tell it’s an unhandled exception that kills the whole controller. We have not been able to find a root cause or a way to force a replication of the error. We have reported this as an issue to our UR distributors as well as directly to NA tech support.

1 Like

We have also (at least) two customers reporting such an issue.
Tech support mentioned, that it could be related to dashboard server calls. Especally if the connection is opened and closed too frequently.
In one application the socket connection is opened and closed for every single dashboard server command. We assume, that this can cause the URControl to crash after some time.
The application was changed to reuse the connection (which is obviously the better way). Unfortunately we have no feedback since this change, so we cannot say, if this resolves the issue.

I asked the customer. Unfortunately the crash of URControl occured again. So the connection to the dashboard server does’nt seem to be the root cause.

We experience the same error quite frequently. We use the UR5 with an RTDE and an external dashboard connection, though reuse the connection throughout.

Our UR5 is used in a demonstrator for trade fairs (e.g. Hannover Messe), tours, etc, so it does not run continuously, though when it does, reliability is very important to us. But it seems every time we run it for longer (>one hour), this error occurs quite often. I checked the logs and all I found was a statement saying “lost connection to controller”.

we are also facing this issue on the new UR10 e-Series. It randomly occurs on startup

To provide more details on this issue, can you please supply screenshots of the PolyScope and Controller log, when this error occurs. When this happens:

  1. Connect a USB keyboard
  2. Press CTRL+ALT+F9
  3. Take a screenshot
  4. Press CTRL+ALT+F10
  5. Take a screenshot
  6. Press CTRL+ALT+F7 (return to PolyScope)

Remember to note your software version used, when uploading screenshots.
The most recent PolyScope release version would be preferable for performing this test.

Even better:

  • after “no controller”, go to initialization screen and press start - controller process will be restarted
  • trigger error report (i.e. by pressing emergency stop button)
  • go to log tab, and save generated report to USB stick
  • file a bug report to your regional TS with error report attached
3 Likes

Hi. I’ve been this problem, and the best option is to work with Polyscope 3.3.4.310, this is the more stable version for me.

I have experienced this same issue. I am installing 2 UR10 CB-series robots running 3.7.2, and they both have this error come up randomly during our error recovery sequence. We are utilizing a TCPIP socket to send ASCII text commands one at a time with confirmations to each robot if a fault/e-stop occurs, and we are not closing the socket until the last text string is confirmed as received.

Any advice that any of you can share about how to either recover from a NO CONTROLLER fault or to avoid it entirely is greatly appreciated.

Hi,

The problem occur this morning on a UR5 E series, here is the report :

thanks

Do you still see this issue, when using the new software 3.8 / 5.2?

Is there anyone who experience that error “NO CONTROLLER” without RGx Gripper ?
In my case that symptom occurs even if robot program, which use RGx, is stopped.
Actually for us, there is no those symptom in case of not installing the RGx.

Can I get help to avoid “No Controller”?

Yes, in our cases, we do not have a RGx Gripper.

I belive, that this issue is related to network functions, maybe RTDE (?) which all our applications (which have this problem) have in common (Profinet).

Unfortunately we cannot test it with the new 3.8 Version, since these robots are running in a production line and we are not allowed to change something.
We only have a chance to update, if we get a statement from UR, that there is a fix, which addresses exactly this error.

Dear hch,
Does your system have no device based on URCAP also?
UR may suspect URCAP and suggest new softwares for them.

In at least one installation there is no URCap installed.

Eventually we have upgraded to 3.8 and same symptom occurs.
Is there any possibility to be related with language.
Our language environment is korean.

1 Like

Have you tried changing it to English, to see if that changes anything?

Hi,

I already try to change the language to English (my robot is in french), no changes