Universal Robots+

Loading a program with socket test via dash board server

Hey thanks for any help in advance.
We have a Ur 10 e with poly scope version 5.3.1
when i try to load a program as per the example given on this page Dashboard Server e-Series, port 29999 - 42728
it returns the syntax " Could not understand load/programs/ test program.urp"

What im trying to do is load a program that is contained on the Ur control tablet. It isn’t working .
I can how ever send the play,pause start,stop command and it will preform the functions on what ever program is already loaded.
So then i thought that maybe i needed to load the file from the Computer system i am using and i tried that with the same result.
The correct syntax or pointers on what i may be doing wrong would help alot .

                                                                                                                                         Thanks

Do you have a space between load and the path? Also, you do not need to include the /programs path

Load /test/program.urp
1 Like

Sorry that was a type o What i have tried exactly was load/programs/test_program.urp.

So i dont need to include a file path to the urp_ program?
so just load/test_program.urp?

And thank you for your help with this issue !!!

There should definitely be a space between command “load” and “\program_path\program.urp”

is it possible to load a urp program using RTDE?

Hi, excuse me for cutting in.

You should use dashboard for loading urp file.
Loading is not able to be used from RTDE.

Thanks for responding!
I need to read data registers from RTDE and jog the robot. So I need to load the URP using the dashboard interface and then read data registers from RTDE Correct?

That is correct.

Loading urp ⇒ dashboard
Reading registers ⇒ RTDE

2 Likes