Universal Robots+

Installing fail urcap-sdk-1.0.0.7 using install.sh

I have failed to install urcap-sdk-1.0.0.7 with the following messages.
So I could not build MyDaemon example. HelloWorld is OK.
I work under URSIm 3.3.0.145 Starter-VMware Workstation 12 Player.

ur@ursim:~/urcap-sdk-1.0.0.7$ ./install.sh
The tool ‘dialog’ is installed…
The tool ‘sshpass’ is installed…
The tool ‘mvn’ is installed…
Installing archetype and API to maven repository…
Installing UR tool chain…
Reading package lists… Done
Building dependency tree **
Reading state information… Done
Package libc6-i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
** libc6

E: Unable to locate package lib32gcc1
E: Package ‘libc6-i386’ has no installation candidate
dpkg: error processing archive urtool/urtool3_0.3_amd64.deb (–install):
** package architecture (amd64) does not match system (i386)**
Errors were encountered while processing:
** urtool/urtool3_0.3_amd64.deb**
Done. Please log out and back in.
ur@ursim:~/urcap-sdk-1.0.0.7$

1 Like

Anyway Currently Only Python MyDaemon works by commenting out the pom.xml in the following way.

<pom.xml>

108 <!--
109                                         <execution>
110                                                 <id>clean-daemon</id>
111                                                 <phase>clean</phase>
112                                                 <goals>
113                                                         <goal>exec</goal>
114                                                 </goals>
115                                                 <configuration>
116                                                         <executable>scons</executable>
117                                                         <arguments>
118                                                                 <argument>-c</argument>
119                                                         </arguments>
120                                                         <workingDirectory>./daemon</workingDirectory>
121                                                 </configuration>
122                                         </execution>
123 
124                                         <execution>
125                                                 <id>compile-daemon</id>
126                                                 <phase>compile</phase>
127                                                 <goals>
128                                                         <goal>exec</goal>
129                                                 </goals>
130                                                 <configuration>
131                                                         <executable>scons</executable>
132                                                         <arguments>
133                                                                 <argument>release=1</argument>
134                                                         </arguments>
135                                                         <workingDirectory>./daemon</workingDirectory>
136                                                 </configuration>
137                                         </execution>
138 
139                                         <execution>
140                                                 <id>copy-daemon</id>
141                                                 <phase>compile</phase>
142                                                 <goals>
143                                                         <goal>exec</goal>
144                                                 </goals>
145                                                 <configuration>
146                                                         <executable>cp</executable>
147                                                         <commandlineArgs>daemon/HelloWorld src/main/resources/com/ur/urcap/examples    /mydaemon/impl/daemon/</commandlineArgs>
148                                                         <workingDirectory>.</workingDirectory>
149                                                 </configuration>
150                                         </execution>
151 -->
3 Likes

Thanks taegon.ha! We were running into the exact same issue, but we’re not familiar with Maven, so this would have taken forever for us to figure out ourselves.

It looks like the root of the problem is that the VM included in the starter package 3.3.0.145 is not ready to compile C++ daemons out of the box for a couple of reasons:

The urtool cross compiler included with the URCAPS SDK appears to be the wrong architecture for the VM, and may have some dependencies that are not satisfied as well.

While playing around with it, I also discovered that the tool “scons” which is required by the process to build the C++ daemon is also not installed. Installing it doesn’t help you unless you can also get the URTools cross compiler installed though.

Notice the SW 3.3.4 release on Friday December 16th.
There has been implemented a fix to the install script.
It will now ask whether you want to install the “UR Tool Chain”. Please note this is designed for running on 64-bit Linux distributions with Intel chip.

Thanks!

I’m running the newest URSim (3.3.4) and I ran into these same issues. Inserting the comment symbols <!-- and --> on lines 108 and 150, respectively, solved this problem perfectly.

Essentially, this problem is caused (as mentioned in a few different posts) by the fact that the C++ version of the daemon cannot properly compile due to how the VirtualBox file is set up.

Actually, MyDaemon fails whenever you load the URCap. I guess it just won’t work on the VirtualBox.

What are the necessary steps to get mydaemon working on the newest URSim 3.3.4?

Hello,
I managed to install the cross compiler and build “mydaemon” sample after installing scons.
When I run the program, I get an error message coming from the program: “Could not set the title in the daemon process.” And the title is never set.
Is there a way to fix this? I’m in Ubuntu 14.04 64-bit, SDK 1.1.0-76, URSim 3.4.0-39.

EDIT: it works running URSim with sudo.

well, i tried commenting out this part in the pom, but now i get:
Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.1:exec (ursim-install-urcap) on project mydaemonswing: Result of /bin/sh -c cd /home/ur/sdk/sdk-1.9.0/samples/swing/com.ur.urcap.examples.mydaemonswing && cp target/mydaemonswing-1.0-SNAPSHOT.jar /.urcaps/com.ur.urcap.examples.mydaemonswing.jar execution is: ‘1’. -> [Help 1]

while installing the maven project. Are there any working daemon examples or a list of things i need for deploying a python daemon?