Universal Robots Forum

UR tool chain package

When I run the install.sh in the SDK, I get an error that the package
architecture does not match system. Is there a 32 bit available or is
there another work-around?

@OnRobot_ebbe,

Most URCaps development can run without the UR Tool chain, so if you are having issues installing it, please remove the following in the install.sh file:

echo "Installing UR tool chain..."
mvn install...
mvn install... 
mvn install...

sudo apt-get install lib32gcc1 libc6-i386
sudo dpkg -i urtool/*.deb

Hi,

I commented the described lines and the SDK is now installed, I think, I don´t know how to check.

But now there´s the next problem. The Helloworld Project does not build.

@generalmidi,
It seems your JAVA_HOME variable is not set. This should probably be sorted out.

Try to run echo $JAVA_HOME to check your JAVA_HOME and try to build again.

This particular step corrects the HelloWorld “cap” however it breaks the mydaemon example.

Yes, I am facing the same problem, I can build helloworld but the same setup fails to build the mydeamon example.
The build error is “Failed to execute goal org.codehaus.mojo …”

Having same issue when building MyDaemonSwing. There was an error on eclipse saying “plugin execution not covered by lifecycle configuration”, I tought it was worked around by setting Eclipse’s preferences > Maven > Errorr/Warning and setting plugin from Error to Ignore. The error appers to be solved on eclipse, but when triying to build with mvn install same error on Mojo plugin appears.

SOLUTION, wordked for me: In Eclipse > Window > Preferences > Maven > Discovery > Open Catalog > (search with “MOJO” keyword and install the two m2e connector missings)
I dont overthink about it by now because just want to deploy MyDaemonSwing for testing.