Universal Robots Forum

I cannot network the robot with my laptop using RoboDK

Hi,

I am trying to connect the robot to my laptop using a direct ethernet connection via RoboDK. My laptop is using wifi-connection, and I tried to network using both DHCP and Static Address --no luck so far.

Polyscope says the network is connected with the green check button, but it does not update robot IP automatically, (remains as 0.0.0.0). I waited a few minutes and still not updating. Tried to use Static Address input using my IPv4 Address, but it also does not work in RoboDK when I tried to connect.

Here’s what my ipconfig showing in the command prompt

Connection-specific DNS Suffix . : indiana.edu
Link-local IPv6 Address . . . . . : fe80::7d32:2282:d63c:d78c%14
IPv4 Address. . . . . . . . . . . : 149.160.228.39
Subnet Mask . . . . . . . . . . . : 255.255.192.0
Default Gateway . . . . . . . . . : fe80::18e8:2:28b7:1%14
149.160.192.1

Can anyone help me??

@kimjeey I have not used RoboDK so I may not be the best help, but have you tried pinging the robot in command prompt when connected via Ethernet (if communication is good you should see 0% loss, this is probably the best way to make sure communication is established with a PC). Also, check your installation tab > Fieldbus and try “Enabling” IP/TCP communication, I believe I had to have one of those tabs working for robot to connect to PC. Lastly, I have not connected a UR yet using DHCP so I can’t help there, when using static address make sure to use the same IPv4 from the PC (minus the last number which needs to be different) and also make sure your Subnet Mask which is 255.255.192.0 is identical on both robot and PC. Last/first resort would be check the “help” tab in RoboDK, should be a guide in there helping you connect to robot. Again, have not used RoboDK so take this advice with a grain of salt, but best of luck getting it to work!

Hi Michael,

Thank you so much for your suggestion. In my understanding, in order to connect to RoboDK, I have to set the polyscope as “remote mode” instead of “local” mode – and I wonder if the Fieldbus will matter as it is a remote control mode. Regardless, I have tried Fieldbus set up as “Enabling” IP/TCP communication before and I was not getting any luck. I will try it again with your suggestion of IPv4 number changes.

Changing the subnet number and the last number of IPv4 IP address might help again. How would you like me to change the number for example? If my IPv4 Address is 149.160.228.39 – should I change 149.160.228.xx? What is your suggestion to change the last number set? I will make sure to have the same subnet mask number for both robot and my computer.

And, to be clear, my robot is basically not connected to any network, and independently sitting alone. I am trying to use an Ethernet cord to my computer that is connected to Wifi internet.

Thanks for your feedback – looking forward to hearing more of your opinions!

Hi @kimjeey,

You should be able to establish the connection either with a direct ethernet cable or with both devices connected in the same network. Here you can find the official RoboDK documentation. Are you able to ping the robot from another device? Try setting a static IPv4 address and see if you can ping from your laptop. You can change just the last digits in the IPv4 address with any number between 1 and 255 that is not used by another device on the same network.

Also, what settings have you enabled in the fieldbus installation tab? There may be a conflict in the communication.

Let me know if you need further support :slight_smile:

Vincenzo

Hi Vico,

The link you attached is the one that I’ve been referring to as well. The problem that I have with this procedure is that I do not know how to “retrieve” the Robot IP as my robot says “0.0.0.0”. If you look at the procedure, the robot already has the IP set up, and RoboDK directly uses that IP instead of inserting IPv4 addresses from the network that I am using through WiFi. So maybe another question will be how to set up the Robot IP first??

I could ping either I am directly connected to the controller or not, and Polyscope indicates that the network is connected with “green check button”. Currently, I am not even connected to the controller, and RoboDK still shows that it is working, so I am not even sure if this is even a reliable way to examine.

I need to re-look at the setting of Fieldbus Installation settings again, but I did I tried both enable/disable settings, and neither worked. Another program that I tried to experiment with is HAL Robotic Frames, and it also requires the Robot IP, and I will need to know how to retrieve the IP address.

I will try to insert different numbers for the last digits between 1-255, and get back here how that went. Thank you for your information!

if your robot says 0.0.0.0 go into the network settings on the robot and create a static ip address.

Hi all,

I have good news to share that I was able to connect with the robot through RoboDK. There were two things that prevented me to connect to the robot;

  1. I wasn’t using the right static IP set up. Our IT technician helped me to set up the right static IP and subnet. As Michael suggested, we used the last number of static IP different from Robot and RoboDK (these two needs to match) in the computer ethernet network setting through its properties. We kept the subnet mask IP the same for all the settings. The images below can be found on RoboDK online manual (at the very bottom of UseDriver manual).

https://robodk.com/doc/en/Robot-Drivers.html#UseDriver


  1. My RoboDK program was initially installed with 32-bit instead of 64-bit by our IT technician – found out that that was making a glitch with the driver in RoboDK. Once I deleted the 32-bit program and updated it to 64-bit, it was running smoothly.

Thank you all for your help!!