Universal Robots Forum

How to mount a VMWare shared folder in URSim

Hi, is there an easy way to mount a VMWare share in URSim?

I’ve tried this command without success:
sudo mount -t vmhgfs .host:/ /mnt/hgfs/
or
sudo mount -t vmhgfs .host:/ /home/ur/shares/
I’m getting the error: “Error: cannot mount filesystem: No such device”.

If I type the command “vmware-hgfsclient” in terminal I get the VMWare share listed up.

Hi Daniel,

I am not that familiar with VMWare, I use Oracle VM VirutalBox instead but here is a quick google search results I came up with -> https://www.vmware.com/support/ws3/doc/ws32_running9.html

It sounds like you didn’t setup the networking setting portion of the setup.

Thank you for the feedback. I tried to mount a windows share, but I got the error message “mount: unknown filesystem type: smbfs”.

I was wondering how to access the shared folders set up in the settings of the virtual machine in VMware workstation.
It should be possible since the mount command in URSim/lubuntu does support vmhgfs.

Does this help?

Create somewhere on your PC a folder called “VM_Shared”.
Go on the settings of the VM than you created. Go to “Shared Folders” and add the folder than you created. “Auto-mount” and “Make Permanent” have to be selected.

Play the VM.
Open a terminal (CTRL+ALT+T) and write:
Sudo adduser ur vboxsf
Reboot.

The shared Folder will be inside of : /media

This method is working for me :slight_smile:

2 Likes

Thank you for the tip which I’m looking for. I believe it will wok in Virtual Box, but not in VMware.

Maybe I’ll switch to Virtual box to test it out.