Universal Robots Forum

How to get ur linux module headers

I would like to use the use joystick direction for ur robot. However, the ur robot linux kernel does not have the joydev.ko module.

I have tried to compile the kernel by myself via download the same version of linux kernel but the kernel reject to insert into because of the header format invalid. I have tried to get the linux-headers-3.14.23-rt20ur because the domain ‘packages.ur-update.dk’ cannot be resolved.

How can I get the ur linux module headers?

Thanks

Hi @yiufai.cheng1, what interface is your joystick using? Most USB game controllers will present themselves as USB serial devices within linux without requiring additional drivers or kernel modules, and inputs captured using something like python pygame library very easily.

I have using the cb3.1-3.15.3 image and my joystick is logitech extreme 3d pro. I have used lsusb to find out the joystick is in the usb list but I can’t find any /dev/input/js0 in the directory.

This problem does not exist in the ursim because the joydev.ko and hid_logitech exist in the module (lsmod). When I use the lsmod on the ur os, no such module exists in the kernel.

By the way, can we allow to get the linux header so that we can build our custom module to the os

I have tried for CB3.1 3.15 version controller (not the simulator) with Logitech extreme 3d pro. no /dev/input/js0 is found in the sytem. I have used ‘lsusb’ command and the joystick brand is show in the list. I have tried jstest and it does not response that.

Any help that i can use the joystick? Thanks

I am not familiar enough help on the kernel module compilation issue, but if it is connection to packages.ur-update.dk that is the problem perhaps this will help. Are you on a mainland China internet connection? I am and I cannot directly access packages.ur-update.dk through a webbrowser without VPN, but with VPN connected I can.

Is it required for DK country to access? My connection is in HK and it is freely access to google etc

No it shouldn’t be DK only. I’m connected to US server.

Edit: I am using a UR laptop, this may be why I can access it but you cannot.

I realize the above response is not particularly helpful :slight_smile: I will look further into the feasibility of adding drivers.

In the mean time the workaround that I have gone with for other similar situations previously is to use a Raspberry Pi as a bridge. You should be able to get the USB drivers working on that, and then a small python script to take those inputs and write them into RTDE registers on the controller. Essentially the same functionality you’d be coding on the controller itself but just on the Pi instead.

Thanks for your suggestion. I will try in this way and you can close this issue

Ok thanks for the confirmation. I can also confirm that the repository server is only available on the UR internal network. So using a more open device as a bridge is the best way to go.