Error while trying to connect PLC to EtherNet/IP

Error while trying to connect PLC to EtherNet/IP.

I am receiving the following error on the polyscope after trying to connect PLC to the robot. I have currently also another URcap installed that makes use the RTDE interface, the XML-RPC interface and a lot of other connections opened. However i am receiving the following error:

I tried to SSH into the Linux computer on the robot and list all the active ports, you can get a view here:


If anyone has any ideas to what is causing it i would be thrilled!

Try uninstalling the CAPs and see if you still get this error. Could be they are allocating IO to the RTDE that should be reserved for the fieldbus communication.


I figured it had something to do with a python Daemon making use of the RTDE interface. If i turn the daemon off while the normal URcap is running i can connect to the Ethernet IP. Soo, i need both the PLC and the RTDE interface for this problem i am currently trying to solve.

Make sure your python daemon is operating in the right range, as specified in the EthernetIP guide here: Ethernet IP guide - 18712 - collaborative robots support