Universal Robots Forum

Can't Connect via FTP in URSim

I’ve recently been working on connecting to the communication interfaces on URSim and have been having some success. Today I tried to connect via FTP and it appears to not be supported.

I have URSim open and then ran the following commands in the terminal
“ftp localhost 22” and "ftp 127.0.0.1 22 "
I got back the following errors
“ftp: localhost: Temporary failure in name resolution” and
“ftp: 127.0.0.1: Address family for hostname not supported”

I suspect its because I manually setup URsim to run in a 64bit version of Ubuntu so I could have daemon support and I forgot to install something related to the ftp server.

Is there something I am doing wrong? or did I overlook a file/package during the installation?

Hi @stefanhe99,

When you connect to the FTP server you’re just getting information about the file system instead of robot status data from the UR controller, so it seems logical that this wouldn’t necessarily be included with the URSIM install.

I’ve just tried this out on my own 64 bit Ubuntu URSIM install and had a similar situation, so just go ahead and follow a guide like the one at the link below to install vsftpd FTP server and then add “listen_port=22” to the config file and you should have the same functionality as the standard URSIM package (which has this preconfigured).

https://www.tecmint.com/install-ftp-server-in-ubuntu/

Final note that might not be relevant once you’ve installed the FTP server: I initially got the same “ftp: 127.0.0.1: Address family for hostname not supported” message before installing the server. Googling this mentioned a lot about IPv4 vs v6, and I noticed that the way I had my network interfaces configured it was for some reason trying to get a v6 address that I don’t think my network supports. Once I fixed this and got my machine on my wifi network with a v4 address the Address family error turned into a standard connection refused error.

1 Like

As @ajp said, with ftp or sftp you will get access to filesystem, nothing else. When you do it on localhost it just does not make much sense, because you already have access to filesystem. If you wanted to do it from external machine, you may also try sftp - secure ftp.

If we knew, what you wanted to achieve, it would be much easier to give you better advice.

I’m planning to ftp files onto the UR Controller and then execute them remotely. I just assumed that the ftp server would be present since I connected to all the other communication interfaces in URsim using localhost as well. It makes sense that there is no ftp server, but I saw an example using “sftp 127.0.0.1 22” and wasn’t sure if it was because of my Ursim being setup incorrectly, URsim not supporting it, a networking error or the example being performed on the UR Controller

Ah yes I forgot that it’s sftp so sharing port 22 with ssh. My above advice might cause some issues if you also plan to ssh into the system. You still need to set up an SSH server on a fresh ubuntu install… but that might be a better approach than installing standard FTP and hijacking its default port.

Hopefully that won’t be too much of a problem since sftp is using sshto do the file transfer.

Thank you for the help :smiley:

Slight typo there. I mean having a standard ftp server and your ssh listening on port 22 would probably cause a conflict. But yeah hopefully you have what you need to move forward now :slight_smile:

1 Like