Variables not displaying when running

I have some variables setup in initialise variables
The variables are Boolean
I set and unset them throughout my program , however I do not see any variable values displayed on any screen or tab when my program is running

This is making debugging very difficult

How do I enable the display of variables so I can track their values

Please advise

do you have some pictures?
i havn´t the problem in this big case , like you

Are you using the “Assignment” option on the programming for declaring the variables or using a script?
If you are using the “Assignment” the variables should be displayed the moment they initialize. If you are using a script, make sure you are declaring them with the reserved word global to make sure they are not local variables (e.g.: global Var1 = False)

Hi all

Surprisingly without doing anything other than turning the machine off and on again, the variables have suddenly appeared again

The whole set of screens showing variables was completely blank, but then now fully available again

I really don’t know how it’s fixed itself as I tried the off on fix many times without success before posting my question

Oh well I’ll have to wait for the issue to come back

Thanks for your responses

We’ve seen the same issue here.
I suspect, but haven’t confirmed that it’s connected to the issue we occasionally see where global values do not get saved to permanent memory -

For example, we run a setup program where the operator enters part dimensions. While the setup program is still running, those values are used. Once the program stops, those values all revert back to the previous values, so when we start our production program the values are wrong.

Restarting the control fixes that issue for a while.
UR is aware of the problem and has been able to duplicate it, but not resolve it so far.
We’ve seen this repeatedly on at least 3 of our 8 UR5e robots. Since we’re aware of it, we can watch out for it, but it cost us a couple days of having to re-sort parts.

I created a program which displays the value of a variable, then overwrites it with a random number, then stops the program.
The operator runs it again, and verifies that the numbers are different. If they’re the same, then the system has slipped into the bad mode and needs to be restarted.

Has this been fixed? We are battling this issue on our manufacturing floor each day. Reboots fix the issue temporarly but that is also causing us downtime while we wait for the robot to restart.

I have confirmed the variables ARE updateing internally but are not updating on the pendant display.

I just read the update notes for 5.11.11

Looks like it IS fixed in that version.

Unfortunately, we’re using 5.11.11 and I just had this issue occur. I rebooted and variables appeared again, but we were already running 5.11.11 the first time I saw this happen.

I’ve had this issue as well. Also on 5.11.11.

Since last week I have started to experience the same error as well. Global variables and waypoints stop displaying in the Run tab out of nowhere after 1 or 2 days and they only show up again after restarting the controller.

The robot I’m working on is a UR3e with Polyscope 5.11.9 and the robot age is 70 days, not even 3 months yet.

We need some UR Support over here @sko @ajp

Hi cgs, could you please create a myUR case for this to ensure the issue is known to our customer service teams?

1 Like

Noticed the same thing on a customer’s robot yesterday. Pretty frustrating, as I added a variable to monitor the TCP force so I could verify something, but it wasn’t showing up.

How long does it take to get approved? I have 3 robots on my manufacturing floor that all have this issue.

I’ve sent my request in for access to the myUR last week with no change as of writing this comment.

It should take a couple of working days at the most. Have you managed to get in and get a response now?

Hi guys,

We are aware of this bug and have been investigating it for a while now. We believe we have fixed a somewhat related one in 5.12.2 (specifically, when an installation variable is being saved as the last part of a program before a Halt), but we are having some trouble fully verifying this, as the issue seems to appear so sporadically.

However, regarding this particular issue where the variables suddenly disappear from the Variables overview, I was hoping to leverage your combined knowledge from the field:

  1. When the variables disappear from the variables tap, does your program then always continue to function? Ie. is it purely visual?
  2. What’s the earliest PolyScope version where you have encountered this?
  3. Have any of you been able to reliably reproduce it? Or noted a specific pattern as to when it happens?
  4. Any other observations that might be useful for us to know?

Any insights are greatly appreciated.


In my case it still happens with sw 5.12.2, I am sending the scripts and reading the variables on tcp-ip communication using an external toolkit.
Everything works fine for about 2-3 hours then the values of the variables are not available anymore. Connecting/disconnecting/estop does not help, only the controller restart solves the issue.

The movement of the robot still works fine, i see the scripts starting and ending in the log section, and also on the status, just the variables are not available anymore.

On sw 5.11.11 when the problem was happening, the variable view screen was freeze, and it was easier to notice the waypoints and variables are not changing anymore, but on 5.12.2 nothing is shown there anymore, just the status is changing between running and stopped while moving.

The script i am using is setting a value before stopping, as you mentioned, value that is used as a feedback that the robot ended the movement to the master LabVIEW program.

  1. Yes, it is visual, programs keep to function as usually, but without displaying anything. This makes debug very hard.
  2. Currently happening on a 5.11.9 UR3e. We have a UR3e with 5.8 where this DOES NOT happen. So the bug appeared either between those two versions or in 5.11.9 specifically.
  3. Not been able to reproduce it yet. It just happens. I am not sure that “sporadically” is a very accurate term, since it always happen, but the reason is yet unknown.
  4. Review the processes that are re-launch on the Run-tab, when re-starting the controller, it might be a process/child-thread linked to it that stops working.

Continuing the discussion from Variables not displaying when running:


any update on this issue???
I’m struggling with this bug realy bad every single day out in the field since we also have the phenomenon, that the variables not only just don’t update anymore. The Variables are also are calculated (or transformed) wrong!

var_1=WaypointX works for a few hours and then it’s starting to write wrong pose-values in this variable. Also restarting the CB won’t solve this issue in this case.

I’m not 100% sure if this bug is linked to the “Variable not displaying” bug but there’s a good chance.

Since downgrading to 5.11.9 won’t work on the latest robots for microcontroller reasons I’m getting realy nervous now. This bug makes the Robot almost unusable for us.



Create a case on myUR as mentioned above. Be specific about the issue making the robot unusable for you and cross your fingers that you get more help than “answer the questions in the forum about this bug”.


seems, this bug(s) has been fixed with Polyscope Version 5.12.4 which just has been released about 2 weeks ago.