Universal Robots Forum

Ur_hardware_interface devel vs install folder

I’m using the UR ROS driver in my project (https://github.com/UniversalRobots/Universal_Robots_ROS_Driver) and have run into the following issue:

When I build the project and source the setup.bash in the devel folder, I can launch the following:

roslaunch ur_robot_driver ur10e_bringup.launch robot_ip:=192.168.1.214

and everything works properly.

However, when I run catkin_make install and source the setup.bash in the install folder, the same command results in the ur_hadware_interface node crashing with the following error message:

[FATAL] [1605125319.557317996]: Did not receive confirmation on RTDE output recipe.
[ERROR] [1605125319.557460047]: Could not correctly initialize robot. Exiting
[ur_hardware_interface-2] process has died [pid 24436, exit code 1, cmd /home/gmr/Desktop/ss/catkin_ws/install/lib/ur_robot_driver/ur_robot_driver_node __name:=ur_hardware_interface __log:=/home/gmr/.ros/log/ae781b9e-2459-11eb-b407-a4bb6dba5566/ur_hardware_interface-2.log].
log file: /home/gmr/.ros/log/ae781b9e-2459-11eb-b407-a4bb6dba5566/ur_hardware_interface-2*.log

I’ve not modified anything in the repo packages (i.e. CMakeLists.txt’s).Has anyone run into this issue, and if so, how did you resolve it?

(Using ROS Kinetic on Ubuntu 16.04)

We are not using the ROS driver. in the project. Instead we are using UR RTDE https://sdurobotics.gitlab.io/ur_rtde/index.html to interface with our robot. If you try to implement our system without changing everything that depends on RTDE you will unfortunately receive an error.

Hello Marshall,

Based on the description of your problem, I believe you tried to do the following in your catkin workspace before launching the ur10e robot in ROS environment.

cd /path/to/catkin_ws/src

# retrieve the sources (replace '$DISTRO' with the ROS version you are using)
git clone -b $DISTRO-devel https://github.com/ros-industrial/universal_robot.git

cd /path/to/catkin_ws

# checking dependencies (replace '$DISTRO' with the ROS version you are using)
rosdep update
rosdep install --from-paths src --ignore-src --rosdistro $DISTRO
 
# building
catkin_make

# source this workspace (careful when also sourcing others)
cd /path/to/home/directory/
source /path/to/catkin_ws/devel/setup.bash

If the above-mentioned commands didn’t give you any errors. Then, you don’t need to explicitly source again the catkin workspace separately from the install folder of your relevant ROS package. In your case, the ROS package is “universal_robot”.

I hope this answers your question.

Best Regards,
Sriniwas

Hi UR Team,

I am not sure that I am the intended recipient of this note.

image001.jpg

@marshall this looks like it shouldn’t happen and I cannot imagine why using an install workspace should change that behavior.