Universal Robots Forum

Unwanted robot movement when spot welding

Hello!
I am integrating a spot weld application with a UR10e at the moment. The weld head is mounted on the robot, and weld nozzle (mounted on a spring) needs to be pushed down about 10 mm for the weld to be successful. However, when the robot is rectracting from the surface, it makes an unwanted horizontal movement which causes a scratch to the copper plate underneath.

Here is a video of the movement: Dropbox - 20210608_105945.mp4 - Simplify your life

My guess is that the force needed to push down the nozzle is too large and the torque it causes makes the robot become slightly offset when it makes the rectrating move. Is there a way to fix this unwanted movement or is the force too much for the the robot to stay accurate?

Best,
Tor

Looks like you’re using MoveJ instead of MoveL.

In the video I’m using MoveL, and it’s also the same result when I’m just jogging the robot up and down :confused:

I would say you either use the direction node until a certain force is met, then retract or when the robot gets to the table, write your current position to a variable and then go to that variable position right after.

It worked! When using the force sensor we discovered that the nozzle only has to be compressed about 1-2 mm to reach the 30 N needed for a good weld. By then adding a relative move moving at 0.5 mm/s just high enough to clear the surface, the robot moved up without any horisontal movements. Increasing the speed to 2 mm/s made the unwanted movements come back, so going slow was the trick.

Thanks for the help :grimacing:

2 Likes