Trouble with program moving the correct TCP orientation

Thank you so much in advance (This is my first UR project so I appreciate your time, patience, and feedback.)


I am having trouble making the movement with the correct TCP and feature.
It seems like I can only get the movement I want manually through the TCP orientation ‘tool’ feature. When I run the program i do not get the same result even though I have selected the correct TCP and feature.

I’ve attached a link which includes:

  • Video 1 (manually moving the TCP orientation with the desired movement)

  • Photo of correct TCP and feature selected in desired move)

  • Video 2 (how the program runs which is not the desired movement)

  • link: UR5e Technical Question - Album on Imgur

again, thank you for your time.

Idealy for this type of application you need to use the Remote TCP option
See attached link. UR+ | Remote TCP & Toolpath URCap from Universal Robots
This gives you the ability to rotate around the fixed tool.

I don’t think using the Tool feature in this case is correct.
Try using the Base frame and the correct TCP and then rotate around Z-axis of your TCP (your TCP should be the middle of the bottom of the bottle). :slight_smile:

Will I be able to teach the Remote TCP without the CAD model for the bottle? Seems like I’ll need a model of the bottle in order to generate a Gcode path which unfortunately I do not have.

Okay sounds good, I’ll try using the base feature when I’m back in the office this morning.

Thank you.