Universal Robots Forum

RTDE Connection not working

Hello,
I am working on RTDE python script for data logging. It is working fine but sometimes it will give error “RTDE disconnected” even I am able to ping the robot IP

The error is like this
INFO:root:RTDE disconnected
ERROR:root:Unable to send: not connected to Robot
Traceback (most recent call last):
File “UR5.py”, line 87, in
if not con.send_output_setup(output_names, output_types, frequency = args.frequency):
File “/home/alstrut/Documents/RTDE/rtde/rtde.py”, line 126, in send_output_setup
if len(types)!=0 and not self.__list_equals(result.types, types):
AttributeError: ‘NoneType’ object has no attribute ‘types’

Hi @rohan.more,

So this looks like the connection sometimes fails to start rather than failing halfway through after being successfully established?

This could potentially be related to a network issue … even though you can ping the robot the connection may be unstable. Are you connecting via wifi? Perhaps try a cable?

Thank you for your quick response.
Yes the problem you mentioned is same we are facing.
Yes I am connecting with Ethernet cable. same code I tried with other UR and working fine. Sometimes it works sometimes it will not.
Is this a problem related to Ethernet port .

It could be related to the port, try connecting the Ethernet cable directly to the motherboard instead. This will bypass the extension that goes to the bottom of the control box which may be causing an issue.

Thank you
I will try this and update soon

Hello,
I directly connected with motherboard. For one day it worked fine, again I come across same error.