Universal Robots Forum

ROS-Capabilities for URCap?

I want to use a UR10 in combination with a ROS System on a separate computer that contains MoveIt and some image processing. The end user should be able to use the application with the polyscope. I’d like to at least have some buttons that send ROS-Messages to the external computer and being able to show some messages (e.g. logs).

Before I implement everything myself, I wanted to ask if someone already implemented some basic ROS functions for URCap/Polyscope.

Nikolas

Nikolas,
Is this what you are looking for.

http://wiki.ros.org/universal_robot

Hello Jacob,

I’m looking for a project that allows me to write an application directly for the teachpanel that sends a ROS-messages to my computer.

1 Like

Hi Nikolas,

Any news on that? I’m also interested in sending ROS messages directly from URCap/Polyscope.

Our use case is that we have a gripper with ROS drivers that we would like to integrate to the UR user interface.

The ROS drivers would be running in a separate computer.

No, nothing new. I attached my FT300 directly to my ROS-PC.

Hello,
Has anyone tried using rosjava in the URCap code? I tried to add rosjava core as a dependency as well as a simple publisher node, but I’m getting a low level Java error when I try to create and execute the node:

ERROR [AWT-EventQueue-0] 14:59:03 06/04/17: Caught an unhandled exception
java.lang.NoClassDefFoundError: Could not initialize class org.apache.xmlrpc.util.SAXParsers
at org.apache.xmlrpc.client.XmlRpcStreamTransport.newXMLReader(XmlRpcStreamTransport.java:176)
at org.apache.xmlrpc.client.XmlRpcStreamTransport.readResponse(XmlRpcStreamTransport.java:181)
at org.apache.xmlrpc.client.XmlRpcStreamTransport.sendRequest(XmlRpcStreamTransport.java:156)
at org.apache.xmlrpc.client.XmlRpcHttpTransport.sendRequest(XmlRpcHttpTransport.java:143)
at org.apache.xmlrpc.client.XmlRpcClientWorker$1.run(XmlRpcClientWorker.java:80)
ERROR [AWT-EventQueue-0] 14:59:03 06/04/17: Caught an unhandled exception
org.ros.exception.RosRuntimeException: javax.xml.parsers.FactoryConfigurationError: Provider for javax.xml.parsers.SAXParserFactory cannot be found
at org.ros.concurrent.RetryingExecutorService$RetryLoop.loop(RetryingExecutorService.java:71)
at org.ros.concurrent.CancellableLoop.run(CancellableLoop.java:56)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)

Has anyone seen this? @jbm any ideas?

Hi,

How can I control the OnRobot RG2FT gripper (urcaps) mounted on a UR5 via the new ROS Driver?

Thank you so much :slightly_smiling_face:
Jan