Universal Robots Forum

Recalculate Checksum after safety setting change without Teach Pendant installed

My company is trying to run a UR robot headless (i.e. without a Teach Pendant). One of the impediments we are facing is changing the safety parameters on the robot without the Teach Pendant.

Does anyone know how the safety checksum is generated for both the safety.conf and urcontrol.conf files? It mentions in the header at the top of the file that there is a supplied tool; however, I have not been able to find this tool anywhere on UR’s website.

Would it be possible to share this tool?

Hi Josh,
Tool is actually built into polyscope. It’s not super easy to use, but basic steps are as following (assuming you’re trying this on virtual machine with simulator 3.5.x):

  • Create base installation with polyscope, save as default.installation
  • Open terminal
  • Go to programs directory
  • Change installation name to default.installation.gz, and use gunzip to extract raw ascii installation file
  • Change values in installation file (no need to compress it afterwards)
  • run
    java -classpath $(echo ~/ursim-current/GUI/bundle/*.jar | tr ' ' ':') -Djava.library.path=/root/GUI/lib com.ur.safety.SafetyCRCUpdater default.installation
    to recalculate checksum, and update installation file

At this point you can load installation through polyscope dashboard server.

NOTE: keep in mind that this interface is for development and testing purposes, and UR does not guarantee that it will stay in the same place, or even be available for future releases.

1 Like

Hi mmi@,

I followed your instructions and edited min|maxJointPosition and min|maxJointRevolutions. For some reason when I run the java command java -classpath $(echo /opt/ursim/GUI/bundle/*.jar | tr ' ' ':') com.ur.safety.SafetyCRCUpdater /opt/ursim/programs.UR10/default.installation" all my changes got “reverted”, i.e. joint limits where back to defaults. Any idea why this is happening?

Hi mmi,

when i run the command, the result said that could not find or load main class com.ur.safety.SafetyCRCUpdater. And I test all the file in the GUI, but also not found the class.

Could you tell me how to resolve the question ?

Thank you very much!

I had troubles running that tool - polyscope got much complicated over last years.
I’ll try to find a way to run this tool.

1 Like