MyDaemon works on ursim3 but not on ursim5

I am trying to run the example mydaemon urcap, but unable to get the daemon process to run on the ursim5.
I am using the starter package VM, which contains sdk-1.13.0 and ursim-3.15.0.106151 and ursim-5.11.0.108249
I tried both the swing and html MyDaemon urcaps, deploying both manually and with maven.
In all cases the urcap installs on the ursim fine, and I can see the MyDaemon tab in the installation menu.
But I am not able to control the daemon process (start/stop) on the ursim5, I just get daemon failing. However, it works fine on the ursim3, I can toggle the daemon process on and off.
Am I missing something? Is there an extra step I need to perform for ursim5? or is it not supported?

Page 48 of urcap_tuorial_html.pdf lists the minimum polyscope versions needed per urcap API version.
It looks like the SDK ships the mydaemon urcap with an API version 1.0.0.30 (from the pom.xml file) which is not compatible with Polyscope V5. I changed the api version in the pom file to 1.12.0 and ran mvn clean install then tried the new urcaps, and still no luck. Ursim3 is still able to start and stop the daemon but ursim5 isn’t

I tried this in both Python and C++

For anyone else having this issue, this is a known bug in the simulator. A workaround is to start the daemon process in a separate terminal before launching the simulator. The status of the daemon will till show failed on the installation page GUI, but it will actually work.