I cannot start daemon (XMLRPCmath)

I installed XMLRPCmath sample urcap to URSim SW3.12.
Sample: XML-RPC Math URCap
But the daemon starting is failed.


I verified that “mathserver.py” is runnable by itself without deploying URSim.


Please tell me what to check to run the urcap.


The “Starter Package SDK 1.8.0” with Ursim 5.5 and 3.11 worked for me.
In 1.9.0 I couldnt start the daemon via ursim. compromise solution is starting the daemon in cmd line but testing features depending on runstate of daemon are not possible.

mentioned here

Thank you for replying.

I verified that the daemon can be started on “Starter Package SDK 1.7.0” & “Starter Package SDK 1.8.0”.

I hope it can be started on 1.9.0, too.
When I am going to start the daemon on this, “service” directory has no file(symbolic link).

Dear UR+ development support:

Please tell me what I can do to run daemon on Starter package 1.9.0.

This problem is solved.
There is the below issue in Starter Package 1.9.0

  1. There is not directory “runsvdir-ursim-” in the directory “/etc/runit/”.

  2. I act “./install.sh” in directory “/home/ur/ursim/ursim-”.

  3. The directory “runsvdir-ursim-” is created in the directory “/etc/runit/”.

  4. Daemon can be started