Universal Robots Forum

Failed modbus connection

I am currently working on a python project aimed at controlling an external tool which is based on an arduino board. I am encountering the following problem:

  • i have tried my code on the Ubuntu 14.04 simulator and it works fine
  • i have tried my code on the robot but it looks that i have some problems in the communication: the robot establishes a connection but this connection fails suddenly.
  • the underling protocol that i have deployed is modbus-tk and i keep getting the following error

File “modbus_tk/utils.py”, line 39, in new
File “modbus_tk/utils.py”, line 37, in new
File “modbus_tk/modbus.py”, line 306, in execute
File “modbus_tk/modbus_rtu.py”, line 46, in parse_response
modbus_tk.exceptions.ModbusInvalidResponseError: Response length is invalid 0

I have tried to lower the baude rate up to 9600 think about a communication speed related problem but this did not solve my problem.

does someone have any guesses?
thank you for your cooperation