Defined Waypoint has 2 different positions?

Hi, I have something wacky going on with my “home position” waypoint.

I have a waypoint programmed as HOME_POSITION and reference it in several locations throughout my program, but some are showing up as in a slightly different location (like a few inches forward or backward). The position is linked in all instances and there is no evidence of any other waypoint named even close to the same name.

I moved the robot to my desired position and retaught all of the instances of HOME_POSITION, but the had the same issue.

Then I tried cycling power on the robot, same issue.

Next I created an entirely new waypoint called HOME and replaced all of the HOME_POSITION waypoints with the new HOME waypoint (inserted a new waypoint and deleted the old, did not just relink the waypoint). Same issue with the HOME waypoint now.

Anyone seen this before?

I also tried moving the position to a slightly different xyz location and had the same issue.

Are you using more than one TCP?

With the cobot, yes, but not with this program. To create this program, I copied another program that uses the same EOAT. The home position for the original program is about a foot higher than the home position for this program.

Does it move to the wrong location when you Jog to it, or only when you are playing the program? I remember beating my head against a wall trying to understand a similar behavior, and it ended up being my “Active TCP” was different than it was at runtime. So during the program running, there was an appropriate “Set TCP” call, but when I was jogging to it, my active TCP was incorrect. Didn’t know if something like that is what you’re also running into. If the program you copied from is that drastically different, I would wager your TCP data is not the same between the two robots, or one was using a Feature or something that didn’t transfer over.