Universal Robots Forum

Dashboard Server commands (except two) stopped working after Firmware update 5.8.x to 5.9.x

Hi Forum Members,

Dashboard server commands provide the possibility to control the robot from a remote controller like PC, PLC etc

we have been working with the Firmware version 5.8.x. all the dashboard server commands have been working and now after update of the firmware to 5.9.x the dashboard server commands have stopped working except for the folliwng two

  • get serial number
  • get robot model

we also checked the logs for the dashboard related errors. but nothing was to be seen related to dashboard

does anyone have an idea. what the reason could be behind this error. has anything changed in the command syntax etc.

please provide me with a solution.

Regards

Just to check, is the behaviour different with remote control mode on or off? Also, I don’t know if this is important but the 5.8->5.9 upgrade resets a bunch of linux stuff. Has it messed with your network settings?

Hi @terryc ,

In the mean i could find the reason.

with 5.8.x i was sending play ‘\n’ to UR. the same didnot work with 5.9.x, ti tried removing the CR and now its working

Glad to hear you got it working. I just looked back on some legacy code and it looks like sending the string ‘play\n’ has always worked over the python socket library since at least 5.1. Just out of curiosity, what were you sending it with? Some graphic interfaces don’t really specify exactly what they are sending but they usually add on their own \n.