VM URSim + ROS2 foxy. Connection problem

Hi everyone,

I am trying to develop an application to control the UR10e using ROS2 foxy installed on Ubuntu 20.04 LTS.

  1. I built the ROS2 driver (foxy branch) in my ros2 workspace and I am trying to connect it to the URSim using the External Control 1.0.5 URCap.
    (The URSim version is 5.13 and it is running on a VM).

  2. I installed the External Control URCap and set up the URSim by inserting my Host PC IP address.

  3. My Host PC (where the ros2 application should run) and the VM are correctly communicating and I could check it by using: ping + IP_address_host_pc on the VM and ping + IP_address_guest on the host PC.

  4. Then I unlock the 50002 custom port by using nc -lk 50002.

The problem comes when I run the program on the URSim and the launch file through:
ros2 launch ur_bringup ur_control.launch.py ur_type:=ur10e robot_ip:= use_fake_hardware:=true launch_rviz:=false

the URSim shows me the window “Starting Program, please wait…” but then it remains like this and does not happen a thing:

Actually, even when I do not run the ros2 launch file I still get the same issue.

WhatsApp Image 2023-02-24 at 12.23.56

The IP addresses are:
My host PC:

The VM is running with a Bridged Adapter.