UR-5E Internal FT Sensor Shows Force After Force Removed

I have a UR5e and am using the FT sensor in my application. It works very well, but runs into problems. Here is an example:

I am moving to waypoint until I see a force of 20 in the z direction. The movement stops and then I move on to the next step of the program where I will use the force in the z direction again, but it is still reading 20. It doesn’t update when no force is there, and I would expect a near zero value.

The problem goes away somehow, but I don’t know how. I do not see a “zero_ftsensor()” function in my software. How do I zero or tare between steps? Is zeroing the correct idea here?

I run the get tcp force function in a thread, write the values to x_force, y_force and z_force variables. and use them throughout the application.

Yes use the zero_ftsensor() command any time before calling an experession until force() > X

1 Like

Thanks for the reply. I don’t see that function in my dropdown list.

Hopefully I am just missing it. Can you please be a little more specific on how to implement it?

I tried adding a script to my program then searching the function dropdown menu.

You can just type it in manually with the on-screen keyboard.

1 Like

thanks, Eric. That worked. I must have typed it wrong or had a wrong syntax the first time I tried to manually enter it. It seems to be running and working now.