Trying to use RTDE from simulator

Hello, I have a problem with RTDE communication not working between host with simulator and another device on the same network. About 2 months ago everything was working fine, but last week when I was about to do some test I was not able to connect to the RTDE controller.
I am also using primary / secondary interfaces, which both work fine. Some technical info:

  • sb_release -a gives:

    • No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04 LTS Release: 14.04 Codename: trusty
  • Using VirtualBox 6.1.30

    • tried with bridged connection → could not connect
    • tried with bridge + NAT (with port forwarding to 30004) → could not connect
  • URSim UR3, 5, 10, 16 all fail

Tried to run script from (GitHub - ryanpennings/RTDE_UR: Real Time Data Exchange streaming for universal robots. (Streams points to robot, for running large files)):

python --host
Universal Robots - (semi) Real Time Point Streaming ring buffer
Ryan Pennings - 2021
For enquiries/suppport visit:

loading files...
tcp.txt loaded
printing.txt loaded

Robot Connected
Waiting to send TCP - please start robot program now.…
no data received in last 1 seconds
No State
Traceback (most recent call last):
  File "C:\Users\mikel.irazola\Downloads\RTDE_UR-master\", line 287, in <module>
  File "C:\Users\mikel.irazola\Downloads\RTDE_UR-master\", line 161, in main
    if state.output_int_register_0 == 2:
AttributeError: 'NoneType' object has no attribute 'output_int_register_0'