ROS UR control via Docker - ports

I’m trying to run the UR ROS drivers from within a docker container. I can run just fine from outside the container, but my joint trajectory controllers stop immediately after startup when I’m inside the container. My current thought is that there is a communication issue here. I am forwarding port 50002 to inside the container. Should I be also forwarding other ports?


Figured it out.

Had to run the container with --network="host"

1 Like

sorry for not answering this earlier. Please see also this post.

No worries. I will say that I tried the solution in that thread - opening ports 50001,50002, and 50003, and while I could communicate some things w/ the arm (the urcap program could run), the ros_controllers were still stopping. (not crashing, but just going to the stopped state. It’s only when I went to host networking over the container that everything worked. I used nmap a bit while troubleshooting in the non-docker configuration, and there were other open ports on the control box outside that range.