ROS Drivers connect to UR10e but do not send commands

Hi all,

I have recently begun working with UR robots, specifically a new UR10e. Thus far I have been working in simulation with URSim (where everything is working), but have started trying to run on the actual robot. Today I finally managed to get the networking to work and can ping the robot. I then tried to run the ROS2 Humble driver using the command ros2 launch ur_robot_driver ur_type:=ur10e robot_ip:= launch_rviz:=false use_fake_hardware:=false fake_sensor_commands:=false . If I run ros2 topic list in another terminal I get all the right topics and the /joint_states topic is publishing the correct states.

However, the robot does not move if I publish commands. I am first trying to simply send URScript commands via the /urscript_interface/script_command topic. The robot is on and started, I assume the networking is working since I am receiving telemetry, and the “Remote Control” setting on the pendant is enabled. I am not messing much with the URCaps since the URScript will overwrite the existing program anyways right (although I have tried enabling external control via URCaps as well and it has not worked)? The command I am sending is more or less:

ros2 topic pub --once /urscript_interface/script_command std_msgs/msg/String '{data:
"def my_prog():

  set_digital_out(1, True)

  movej(p[0.2, 0.3, 0.8, 0, 0, 3.14], a=1.2, v=0.25, r=0)

  textmsg(\"motion finished\")


As found in Usage — ur_robot_driver documentation. The ur_robot_driver terminal window clearly receives the URScript command, but the robot never moves. For further context, the final few lines of output when I start the driver and then publish to the URScript topic is:

[ur_ros2_control_node-1] [INFO] [1717799228.125554666] [joint_state_broadcaster]: 'joints' or 'interfaces' parameter is empty. All available state interfaces will be published
[ur_ros2_control_node-1] [INFO] [1717799228.130092665] [controller_manager]: Configuring controller 'io_and_status_controller'
[spawner-6] [INFO] [1717799228.143923861] [spawner_scaled_joint_trajectory_controller]: Configured and activated scaled_joint_trajectory_controller
[spawner-10] [INFO] [1717799228.148312180] [spawner_force_torque_sensor_broadcaster]: Configured and activated force_torque_sensor_broadcaster
[spawner-9] [INFO] [1717799228.152200674] [spawner_speed_scaling_state_broadcaster]: Configured and activated speed_scaling_state_broadcaster
[spawner-7] [INFO] [1717799228.156140278] [spawner_joint_state_broadcaster]: Configured and activated joint_state_broadcaster
[spawner-8] [INFO] [1717799228.165957595] [spawner_io_and_status_controller]: Configured and activated io_and_status_controller
[INFO] [spawner-11]: process has finished cleanly [pid 1277349]
[INFO] [spawner-10]: process has finished cleanly [pid 1277347]
[INFO] [spawner-6]: process has finished cleanly [pid 1277339]
[INFO] [spawner-9]: process has finished cleanly [pid 1277345]
[INFO] [spawner-7]: process has finished cleanly [pid 1277341]
[INFO] [spawner-8]: process has finished cleanly [pid 1277343]
[urscript_interface-4] [INFO] [1717799242.907352265] [urscript_interface]: def my_prog():
[urscript_interface-4] set_digital_out(1, True)
[urscript_interface-4] movej(p[0.2, 0.3, 0.8, 0, 0, 3.14], a=1.2, v=0.25, r=0)
[urscript_interface-4] textmsg("motion finished")
[urscript_interface-4] end

I have no idea what could be occurring or what to check, any help is appreciated. Thank you!!