Program won't play

I am several weeks into programming my latest UR10e and now it has decided to be moody.

When I hit ‘play from beginning’ the system should run my “before start code” and go to home position and clear IO but instead nothing is happening.
I even tried adding a breakpoint in that section of code but nothing happens. Button just stays as a little play icon.
Zero alarms or messages in the settings.

The system has zero external IO for start/stop, I am not in remote mode, no estop is active.
I have been running this same program all week without any issues, and have no idea where to start looking.

It would make it immensely easier for us to help you, if you could upload your program and installation files. :slight_smile:

Yeah i will get a screenshot minimally, currently waiting on IT bc they blocked USB access again.

You should take a backup and put up here instead. :slight_smile: Use magic files. Find it in the Download section.

That’s my USB issue, i can’t put the magic file on the USB to get the backup off the robot… :angry:

I’ll get something up here shortly. I left my system powered down last night to give it some time to think about its life. Maybe it’ll just behave this morning.

Are you using the built-in palletizing by chance?

You can see here the system says Normal, and program is not incomplete

But when I hit PLAY FROM BEGINNING, nothing happens.

Script file attached.
EN_AP1.script (162.2 KB)

I have done a full backup & updated to latest software. No change.

Just created a brand new 6 waypoint program.

Start from beginning

/NOTHING/

I have no idea where to go from here.

Even adding a popup or message box, the program is not running at all.

::EDIT::
Started back at default installation, setup robot mounting and a rough TCP/payload. tried the new 6 waypoint job again and it ran. So its something in my installation file?
Removed entire modbus setup and then all those IO from job and still nothing.

Only other things i’ve configured are a plane for my fixture, and my true EOAT values
both of which i don’t want to change bc the waypoints are already taught and ready for production.

@mricchino,

Does your other installation have external device IO configured? If so, are any of them assigned to stop the robot program?

Remote mode won’t prevent a stop signal, only the start signal. If there is a stop signal latched in, it might just be getting stopped every time you press start. When you made the new installation, that external IO is likely no longer configured.

If you go to the log screen and enable the info entries, does anything get populated after you press the start button? If you’re seeing a program stopped entry right after the program start entry, something is triggering that stop.

Have you created a case on myUR so our support team can assist?

https://myur.universal-robots.com/#/

I’d go with the same as miwa. Sounds like you set up an input to stop the robot program.

If you want further assistance, please upload .urp and .installation files. :slight_smile:

Zero IO signals were configured in the installation file.

The log screen showed nothing at all when I tried to run
I started a ticket with my supplier support team, they were able to recreate the issue loading my backup on the simulation software.

Since removing all of my modbus signals and features didn’t solve my issue, i decided to restore from the backup I took that morning, and the system began working normally again. The very same backup that can replicate the issue in simulation now works…

I am going to backup again, and update the software again, and hope it continues to behave after all of that.

Do you have any UR CAPs installed? I’ve had this happen to me in the past with my CAP if I had an exception in the generateScript() method of the CAP. This is only run when saving, or running the program. And if I use try{} catch{}, it doesn’t actually display any error. It just dies quietly. IF any of that is the case here, and it starts happening again, you can try plugging a keyboard into the pendent and pressing CTRL+ALT+F9 (I think) to access the terminal. If the CAP is printing the stacktrace, this is where you could see the error.

I do have the robotiq force copilot URCap installed, and using it as a force control for application. but none of that was new or changed the day the issues started.