Universal Robots+

FixedPositionDefinedWaypoint

Hello!

I am trying to create a waypoint using a predefined pose and joint positions.
The code works in the simulation.
UR software 3.13.0

I found out that the TCP is the difference between simulation and the “real” robot. The simulation has none TCP offset while the robot has a TCP offset of.
X: -0.45mm
Y: 3.33mm
Z: 442.78mm
RX: 1.8598
RY: -1.8526
RZ:0.6056
payload 2.50kg
Center of gravity
CX: 0
CY: -100
CZ: 100

My question is why does this not work on the robot?

Checklist:
I use the correct solution to the pose obtained from a getUserDefinedRobotPosition(new RobotPositionCallback())
The waypoint appears in the tree with the correct pose but not the desired joint position.
I have tried to use the new way introduced in the urcap API 1.10.0, called
createfixedPositionConfig(PositionParameters positionParameters, BlendParameters blendParameters, WaypointMotionParameters waypointMotionParameters); but I can’t make an instance of PositionParameters without a RobotPositionCallback2 that would be okay if I then could save it in the DataModel but the does not have a set method I can use.
I have now tried with the positionParameters but get the same error.


outside the picture, the homeWaypointNode is added to a move tree.
I would really appreciate some help on this matter.