Universal Robots Forum

English Keyboard

I am having trouble getting any connected keyboard to use a standard US English command. If I type “-” I get “+”. The only close option in Setup is Int’l English and that does not work.

Hi @christian.mackin,

This language option in setup will only change the onscreen language, not the keyboard input language. You’ll need to change this within Linux, I don’t have a real robot infront of me to check but I think you need to change the XKBLAYOUT line to =“us” in /etc/default/keyboard and then reboot.