Universal Robots Forum

XMLRPC Pstream Interface Broken With 3.4.1.59

Hi, I am currently using XMLRPC for communication with the robot on our team.

During my use, I noticed that UR Software version 3.4.1.59 broke the pstream in$

Reproduction Steps:
Download the XML-RPC communication example code for C++ and the associated UR P$
https://www.universal-robots.com/how-tos-and-faqs/how-to/ur-how-tos/xml-rpc-com$

We built the C++ program and launched it on the default port: 8080
We then ran the UR program on multiple versions of the simulator 3.2, 3.3.3, an$

For the C++ example, we were using address as directed in the article: "127.0.0$
3.2 and 3.3.3 generated the “Received pose” output as explained in the article.

3.4.1 was unable to connect at all. We tested this on the Simulator and on a Ro$
This raised a message box saying, “Cannot connect to 127.0.0.1 on port 8080”.

@josh, did you try using a different port with the server to see if maybe there is just a conflict with the system? We have had no issues with our servers running the 3.4.x series but we use a different port number.

@mbush I have tried with several different port numbers ranging from 8000 to 51000. In each case, the program reports it cannot connect on 3.4.1.59. On previous software versions there was no issue.

As a little more background, I am running a C++ version of both the abyss and pstream XML-RPC servers (although only one at a time). I am also using the Sourceforge XML-RPC library (version 1.39.12 - the Super Stable release)

To clarify the issue further, if you run the UR XML-RPC example with the xmlrpc address of “127.0.01:8080” you get an error on the Polyscope software. If you run with the address of “http://127.0.0.1:8080” the Polyscope will run but I believe it is expecting an XML-RPC abyss server. If you try using an XML-RPC pstream server the XML-RPC library reports a packet reading error.

On previous software versions the address of “127.0.01:8080” with a C++ implementation of the pstream server worked just fine.