Universal Robots+

URCap and Polyscope Incompatibility

I am still having problems with my URCaps not working on any other version of Polyscope other than then one used in the URCaps Starter Package.

For example, I developed URCap in URCaps Starter Package SDK 1.8.0 (UR sim 5.5.1.82186) and tried installing URCap on a physical UR3e robot with Polyscope software 5.2.0.61336. When I try installing URCap (either manually using USB or using Premote) I get a yellow warning exclamation mark in Polyscope in the the Settings menu under URCaps and the URCap will not work. I also tried upgrading the UR3e to Polyscope 5.3 and 5.4, but same error.

Once I update the UR3e to match the URCaps Starter Package version (polyscope 5.5.1.82186 in this case) the URCap works just fine (green check mark in Polyscope Settings under URCaps). Any ideas on how to fix?

That is exactly as I would expect it.
The API (1.8 in your case) is released with a particular version of PolyScope, i.e. 5.5.
And you cannot use URCaps using this API with older versions of PolyScope, simply because the “old PolyScope” does not know of the new API.

Check out this article.

2 Likes

Thanks for the quick response jbm!

If I’m reading the chart correctly, if developing a URCap as a product for e-Series, it would make sense to develop the URCap in API 1.3, so that it would work for all versions of Polyscope 5.x.x for e-Series? Would you ever run into an instance where a URCap with API version 1.3 would not work on later versions of Polyscope?

Hi Jordan,

I believe that the only compatibility issue you could face was the change made to how polyscope uses the getTitle() and isDefined() method whic were introduced alongside polyscope 3.9/5.3, details of which can be found here. But providing that when you develop URCaps which use earlier APIs, you comply by the behavioural change, I believe you should be okay.
Bare in mind though that using the older APIs will of course limit the functionality available to your URCap.

1 Like