Universal Robots Forum

Ur controller not booting into the polyscope unknown filesystem error

Hi,
I got this error when i started my robot today morning. it says unknown filesystem
i want to know the reason for this error and a plausible solution

Looks like it’s trying to boot from the wrong USB device… what do you have plugged in?

Grub is the bootloader used to boot the linux filesystem. It seems that either you unpluged the storage containing the OS from the robot or the partition got corrupted somehow. You should try a warranty return or in an emergency situation you can try to reinstall the linux OS supplied but UR on the robot PC.

yes, its the same pendrive with serial number on it which is connected to the controller.

#david.fira-mladniesc,

please share guidelines to updates linux operating system on UR controller.

Do you have any other USB devices plugged in besides the standard system disk?

negative, no other external devices plugged in

Have you been working on anything related to the linux system that could have resulted in the disk no longer being bootable?

So to rewrite the OS image you should follow this link https://www.universal-robots.com/download/?option=28916#section18982
But please do note that the I think you need to recalibrate the robot after the new OS install.
My advise is to contact your nearest UR supplier and ask for their support because what you are about to attempt is a bit risky and you might not cover all the setup steps, thus leading to miss configured hardware.

EDIT: Also when you download the software be sure to select the Control Box (CB) that you have.

Thank you , i will contact the UR team for support