Universal Robots Forum

Connecting UR5e to Ubuntu

Hey everyone,

i am new at the field of robots. I try to connect my Universalrobot 5e via direct ethernet connection to my ubuntu pc. The problem is, that the first ethernet connection at the pc is for internet and the company server. Via the second port i want to communicate to my robot. But here is the problem. I connect my robot physically directly to the PC and the PC can’t connect. On the robot i have the following network settings (they were such as they are and it worked with windows)

  • IP address: 169.254.64.7
    
  • subnet mask: 255.255.255.0
    
  • Default gateway: 0.0.0.0
    
  • Preferred DNS server: 192.168.1.1
    
  • Alternative DNS server: 0.0.0.0
    

I hope i could pointed out my problem and hope someone can help me. Maybe someone had the same problem before.
Thanks a lot!

So you’ve got a dual boot machine that runs both Windows and Ubuntu natively? Or you’re running Ubuntu within a virtual machine on Windows?

How is the IP address of the PC configured?

Did you get this worked out?
Can you post your result from the ubuntu pc runming ifconfig -a?
It appears you may have an IP config issue.

I think i solve the problem. Linux couldn’t find the robot because i connected it to the second ethernet port of the PC. I have to set up some configs manually. Due to Corona i cant test it. Thanks for your help!